Zum Inhalt springen

[Feedback] DPI-Skalierung


Empfohlene Beiträge

Eine Nachricht von Jon Olson:

Hallo Leute! Im Update vom 17. Oktober 2017 haben wir eine mit hohen DPI-Werten kompatible Skalierung bereitgestellt. Da viele von euch Fragen und Anregungen zu diesem Feature zu haben scheinen, möchten wir euch bitten, diesen Thread für euer Feedback zu verwenden.

Hier ist eine kurze Beschreibung der Funktionsweise der DPI-Skalierung: macOS und Windows bieten einen Skalierungswert, der in der Regel von Auflösung und Abmessungen des Monitors abhängt. Seit Erscheinen des Patches vom Dienstag verwendet der 64 Bit Client ebenfalls diesen Wert zur Skalierung des Ingame-UI. Ihr könnt den Skalierungswert in den Einstellungen eures Betriebssystems ändern. Bitte verwendet eure bevorzugte Suchmaschine, um die entsprechenden Einstellungen für euer Betriebssystem zu finden.

Uns ist bekannt, dass es Abstürze gegeben hat, die mit diesem Feature in Verbindung stehen. Wir hoffen, schon bald ein Lösung für diese Probleme bereitstellen zu können. In der Zwischenzeit könnt ihr in diesem Thread gerne euer Feedback posten.

Link zu diesem Kommentar
Auf anderen Seiten teilen

Hallo,

ich hab das Problem, dass seit dem Halloween Patch meine Einstellung zur Grafik total verrückt spielen. Zum einen ist mein Launcher sehr groß geworden, so das er fast meinen ganzen Bildschirm einnimmt.Zum anderen habe ich im Spiel selbst auch eine sehr vergrößerte Einstellung.In den Grafikoptionen habe ich selbst nichts geändert.Ich kann, wenn ich den Haken aus den DPI raus nehme, die Grafik wieder normal machen. Nur leider merkt sich Guild Wars das nicht und immer wenn ich mich auf einen anderen Charakter umlogge, muss ich es neu einstellen. Das alles ist Mega nervig und sorgt nicht grade dafür, dass ich spielen will weil alles verschoben ist.MFG

Link zu diesem Kommentar
Auf anderen Seiten teilen

Jemand im EN-Forum hat folgende "Lösung" für das Problem gepostet, dass die DPI-Einstellung nicht gespeichert wird:

  • geh im Spiel in die Optionen und setzte die DPI-Skalierung auf was immer Du haben willst (an/aus)
  • ändere die Einstellung für "Schatten" auf irgendwas (also wenn Du z.B. "Hoch" eingestellt hast, stell es auf "Niedrig" -> spielt keine grosse Rolle - sie muss sich nur ändern!)
  • beende das Spiel
  • starte das Spiel neu
  • ändere die Einstellung für "Schatten" wieder auf den alten Wert

Das sollte dazu führen, dass die DPI-Skalierung sauber gespeichert wird.

Link zu diesem Kommentar
Auf anderen Seiten teilen

@Nico.1527 schrieb:Ich weiß nicht, ob es etwas damit zu tun hat, aber seit dem Halloween Update ist mein Mauscursor extrem groß, was etwas nervt. Kann man irgendwas machen, dass der wieder die alte Größe erhält?

Ich habe einfach das Häkchen bei der neuen DPI-Funktion entfernt und nun ist im Spiel wieder alles beim Alten.Leider ist auch bei mir der Launcher seit dem DPI-Patch extrem riesig und ich weiß nicht, wie ich den kleiner bekomme.

Link zu diesem Kommentar
Auf anderen Seiten teilen

Das, was ihr als riesig bezeichnet, ist vermutlich richtig. Vorher war es vermutlich zu klein und falsch. Also an dem Layout gemessen, das sich die Entwickler ausgedacht und sich vorgestellt haben.

Vielleicht postet ihr mal Screenshots vom Gesamtbildschirm, um zu zeigen, wie es bei euch aussieht. Und schreibt dazu, auf welcher Bildschirmgröße (wieviel Zoll Diagonale) ihr das anschaut, und welchen Wert die dpi-Skalierung in Windows eingestellt ist.

Die dpi-Skalierung ist dafür gedacht, dass Schriftgrößen und UI-Größen ungeachtet der Pixeldichte des Monitors immer gleich groß angezeigt werden. So richtig gemerkt hat man das erst, als die 4K Monitore rauskamen, die zwar eine doppelt so hohe Auflösung haben, aber immer noch im wesentlichen gleich groß sind (24-27 Zoll).

Kann man auf einem 1920x1080 27" Monitor eine Schrift mit 10 Pixel Größe ganz gut lesen, ist das auf einem 4k Monitor mit 3840x2160 so winzig, dass man das nicht lesen kann. Dafür wurde die dpi-Skalierung gemacht: Für einen 27 Zoll 4k Monitor stellt man dort 200% ein, weil der doppelt so viele Pixel wie ein 27 Zoll Full HD Monitor anzeigt. Windows und alle Anwendungen sollen das auslesen und Schriften und UI-Elemente 200% groß anzeigen, also doppelt so groß. Also doppelt so große Schrift bei doppelter Auflösung und gleicher Monitorgröße ergibt im Endeffekt gleich große Schrift. Es ist dadurch nur weniger pixelig, aber die Größe in Zentimetern ist gleich.

Wenn du also jetzt in GW2 alles viel zu groß empfindest, dann gehe in die Option, die die UI-Größe anpasst: das ist in F11 die Option "Interface-Größe". Damit stellst du die Größenverhältnisse in GW2 nach Wunsch auch kleiner ein. Wenn du irgendwann mal einen 4k Monitor kaufst, der plötzlich die doppelte Auflösung hat, aber immer noch die gleiche Größe, dann musst du nur in Windows die dpi-Skalierung für diesen Monitor auf 200% stellen, und dann stellt sowohl Windows als auch GW2 als auch jegliche andere Anwendung, die die dpi-Skalierung berücksichtigt, alles wie gewohnt in lesbarer Größe dar. Aktuell gibts noch viele Anwendungen, die das nicht berücksichtigen, und die werden kleiner und kleiner bis zur Unlesbarkeit dargestellt, wenn man zu höheren Auflösungen wechselt, aber die Monitorgröße nicht entsprechend mitwächst.

Viele Leute haben in dem Bereich ihren Rechner nicht korrekt eingestellt: viele Leute verwenden z.B. nicht die native Auflösung ihres Monitors und regulieren die Schriftgröße über die Auflösung, anstatt in Windows die dpi-Skalierung einzustellen. Damit wird das Bild zwar weniger scharf, aber alles wird größer. Das ging früher gut, als die dpi Dichte nur wenig variiert hat, also als die Bildschirmgröße mit der Auflösung gewachsen ist. Aber jetzt, wo es plötzlich die doppelte dpi gibt, also doppelte Auflösung bei gleicher Bildschirmgröße, ist das so nicht mehr machbar.

Link zu diesem Kommentar
Auf anderen Seiten teilen

Naja, ich hab meinen Bildschirm auf maximaler Auflösung (Ja ich weiß, 1440x900 ist heutzutage lächerlich) Weswegen ich den DPI Wert nur auf 105% habe.(Ja, ich brauch die 105%, da ich 2m weit weg von meinem Monitor sitze)Allerdings verstehe ich nicht, warum diese 105% das normale UI, mit dem ich bisher keine wirklichen Schwierigkeiten hatte, um etwa 5%, vergrößern (Was komplett verständlich ist) , den Mauszeiger jedoch um etwa ...105%? Entweder haben sie da versehentlich nicht 105% sondern +105% gelesen für den Mauszeiger, oder sie haben eine etwas seltsame Vorstellung davon was für eine Vergrößerung der Mauszeiger braucht. Außerdem ist eine Verdoppelung der Maße für den Mauszeiger leider eine Vervierfachung seiner Fläche, was definitiv zu viel verdeckt.

Btw, danke für den Tipp mit dem DPI Häkchen, jetzt ist mein Mauszeiger endlich wieder erträglich

Link zu diesem Kommentar
Auf anderen Seiten teilen

Hallo,mit dem DPI-Scaling wurde ja bekanntlich 3D kaputt gemacht. Mit dem heutigen Update stürzt das Game zwar nicht mehr mit aktivierten 3D ab aber es wird sobald man den Charakter gewählt hat einfach 3D ausgeschaltet.

Ich hoffe das hierzu noch eine richtige Lösung folgt und keine "ich schalte das Feature einfach aus"-Lösung bestehen bleibt.Ich habe mit die Tage extra wegen Guild Wars 2 eine nvidia 3D Visions gekauft.

Link zu diesem Kommentar
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Account erstellen

Erstelle einen neuen Account für unsere Community. Es ist einfach!

Neuen Account erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
 Teilen

×
×
  • Neu erstellen...